Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
The Maze of Galious
 Brain Games Forums : The Maze of Galious
Subject Topic: help installing on winXP and Mac OS X Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
Longey_Nowze
Newbie
Newbie
Avatar

Joined: 30 September 2003
Location: United Kingdom
Posts: 15
Posted: 07 October 2003 at 14:37 | IP Logged Quote Longey_Nowze

ok this what exactly what happens:

  1. I start up the game
  2. I get the blue screen with te Konami® logo
  3. I get to the main screen of the game where it asks me to press space key
  4. I press the space key, the words start flashing and I hear the start up sound
  5. after that the game unexpectedly quits


I found the crash log for MoG this is the last one but they all seem to be the same:

Date/Time: 2003-10-07 14:36:48 +0300
OS Version: 10.2.8 (Build 6R73)
Host:       Host3

Command:    MoG
PID:        387

Exception: EXC_BREAKPOINT (0x0006)
Code[0]:    0x00000001Code[1]:    0x8fe01220

Thread 0 Crashed:
#0   0x8fe01220 in halt
#1   0x8fe10654 in link_in_need_modules
#2   0x8fe10270 in bind_lazy_symbol_reference
#3   0x8fe00e60 in stub_binding_helper_interface
#4   0x000f2b48 in OGG_open
#5   0x000efa14 in init_sample
#6   0x000efe64 in Sound_NewSample
#7   0x000f00dc in Sound_NewSampleFromFile
#8   0x000d0cf0 in Sound_create_stream(char*)
#9   0x000d0df0 in Sound_create_music(char*, char*, char*)
#10 0x0003a374 in GameCycle(unsigned char*, int, int)
#11 0x000c805c in Render(SDL_Surface*)
#12 0x000c5b64 in SDL_main
#13 0x000048f0 in -[SDLMain applicationDidFinishLaunching:]
#14 0x97dfab58 in _nsNotificationCenterCallBack
#15 0x901684d0 in _postNotification
#16 0x90165be4 in _CFNotificationCenterPostLocalNotification
#17 0x9318a720 in -[NSApplication _sendFinishLaunchingNotification]
#18 0x93161624 in _requiredAEEventHandler
#19 0x91b56570 in aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*)
#20 0x91b590cc in dispatchEventAndSendReply(AEDesc const*, AEDesc*)
#21 0x91b56478 in aeProcessAppleEvent
#22 0x96a83778 in AEProcessAppleEvent
#23 0x9308e0a8 in _DPSNextEvent
#24 0x930a0158 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
#25 0x930b1d88 in -[NSApplication run]
#26 0x00004844 in CustomApplicationMain
#27 0x00004c3c in main
#28 0x00003f5c in _start (crt.c:267)
#29 0x00003ddc in start

Thread 1:
#0   0x90073ba8 in mach_msg_trap
#1   0x90005ed0 in mach_msg
#2   0x901489f0 in __CFRunLoopRun
#3   0x90180f58 in CFRunLoopRunSpecific
#4   0x9465c1c0 in HALRunLoop::OwnThread(void*)
#5   0x946511b0 in CAPThread::Entry(CAPThread*)
#6   0x90020c28 in _pthread_body

Thread 2:
#0   0x90042588 in semaphore_timedwait_signal_trap
#1   0x9003e7b4 in _pthread_cond_wait
#2   0x94643ac4 in CAGuard::WaitFor(unsigned long long)
#3   0x946432b0 in CAGuard::WaitUntil(unsigned long long)
#4   0x946422e0 in XThreadedDevice::IOThread()
#5   0x94655a24 in XThreadedDevice::IOThreadEntry(void*)
#6   0x946511b0 in CAPThread::Entry(CAPThread*)
#7   0x90020c28 in _pthread_body

PPC Thread State:
srr0: 0x8fe01220 srr1: 0x0002f930               vrsave: 0x00000000
   xer: 0x20000000   lr: 0x8fe09bd8 ctr: 0x00000000   mq: 0x00000000
    r0: 0x00000004   r1: 0xbfffde30   r2: 0x8fe0b794   r3: 0x000000cb
    r4: 0x00000000   r5: 0x000000cb   r6: 0x0000000a   r7: 0x6d697865
    r8: 0x6420746f   r9: 0x00000000 r10: 0x8fe4850c r11: 0x00000009
   r12: 0x8fe71af2 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
   r16: 0x00000000 r17: 0x00000000 r18: 0x00000002 r19: 0x00000000
   r20: 0x001adf50 r21: 0x0d9a1072 r22: 0xa3075950 r23: 0xbffff1d0
   r24: 0xa3075950 r25: 0x00109bfc r26: 0x0013b8a0 r27: 0x0013ffcc
   r28: 0x8fe4841c r29: 0x8fe484ec r30: 0x8fe484ec r31: 0x8fe0995c


Thank You
MaT
Back to Top View Longey_Nowze's Profile Search for other posts by Longey_Nowze Send Private Message Add to Buddy List
 
Longey_Nowze
Newbie
Newbie
Avatar

Joined: 30 September 2003
Location: United Kingdom
Posts: 15
Posted: 07 October 2003 at 14:47 | IP Logged Quote Longey_Nowze

here is the console log too, it's very interesting:

Mac OS X Version 10.2.8 (Build 6R73)
Initializing SDL video subsystem.
SDL driver used: Quartz
SDL video subsystem initialized.
Initializing SDL audio subsystem.
SDL audio subsystem initialized.
Initializing SDL_mixer.
    opened sndmgr at 44100 Hz 16 bit stereo, 4096 bytes audio buffer
    compiled with SDL_mixer version: 1.2.4
    running with SDL_mixer version: 1.2.5
Set the video resolution to: 640x400x8
dyld: /Users/mat/Desktop/MoG/MoG.app/Contents/MacOS/MoG Undefined symbols:
/Users/mat/Desktop/MoG/MoG.app/Contents/MacOS/MoG undefined reference to _ov_open_callbacks expected to be defined in SDL_mixer
Oct 7 14:36:48 Host3 crashdump: Crash report written to: /Users/mat/Library/Logs/CrashReporter/MoG.crash.log

Initializing SDL video subsystem.
SDL driver used: Quartz
SDL video subsystem initialized.
Initializing SDL audio subsystem.
SDL audio subsystem initialized.
Initializing SDL_mixer.
    opened sndmgr at 44100 Hz 16 bit stereo, 4096 bytes audio buffer
    compiled with SDL_mixer version: 1.2.4
    running with SDL_mixer version: 1.2.5
Set the video resolution to: 640x400x8
dyld: /Users/mat/Desktop/MoG/MoG.app/Contents/MacOS/MoG Undefined symbols:
/Users/mat/Desktop/MoG/MoG.app/Contents/MacOS/MoG undefined reference to _ov_open_callbacks expected to be defined in SDL_mixer
Oct 7 14:37:23 Host3 crashdump: Crash report written to: /Users/mat/Library/Logs/CrashReporter/MoG.crash.log

Oct 7 14:43:44 Host3 WindowServer[185]: CGXDisableUpdate: Updates disabled by connection 0x510f for over 1.000000 seconds

Initializing SDL video subsystem.
SDL driver used: Quartz
SDL video subsystem initialized.
Initializing SDL audio subsystem.
SDL audio subsystem initialized.
Initializing SDL_mixer.
    opened sndmgr at 44100 Hz 16 bit stereo, 4096 bytes audio buffer
    compiled with SDL_mixer version: 1.2.4
    running with SDL_mixer version: 1.2.5
Set the video resolution to: 640x400x8
dyld: /Users/mat/Desktop/MoG/MoG.app/Contents/MacOS/MoG Undefined symbols:
/Users/mat/Desktop/MoG/MoG.app/Contents/MacOS/MoG undefined reference to _ov_open_callbacks expected to be defined in SDL_mixer
Oct 7 15:27:44 Host3 crashdump: Crash report written to: /Users/mat/Library/Logs/CrashReporter/MoG.crash.log

2003-10-07 15:29:02.183 loginwindow[332] Could not find image named `bang'.



I hope this helps.

Thank You
MaT

P.S. I'm not an expert in programming, I'm barely an amateur, but I do some basic C programming, VERY BASIC, if you need any help with at least testing anything I'll be glad to offer any help I can, it's the least I can do.
Back to Top View Longey_Nowze's Profile Search for other posts by Longey_Nowze Send Private Message Add to Buddy List
 
Popolon
Admin Group
Admin Group
Avatar

Joined: 05 November 2002
Location: Spain
Posts: 3135
Posted: 07 October 2003 at 15:33 | IP Logged Quote Popolon

Well, there's only a thing that is not right on this console trace:

- I've compiled MoG with SDL_mixer 1.2.4, and you have the version 1.2.5

Try downloading the SDL_mixer framework that I've uploaded to the main page. May be that works. The problem is in the load_OGG function (the function to open an OGG music file). May be the OGG decoder has ben updated from v1.2.4 to v1.2.5 of SDL_mixer. That are things that happen whit libraries that are still under development...
Back to Top View Popolon's Profile Search for other posts by Popolon Visit Popolon's Homepage Send Private Message Add to Buddy List
 
Longey_Nowze
Newbie
Newbie
Avatar

Joined: 30 September 2003
Location: United Kingdom
Posts: 15
Posted: 07 October 2003 at 15:56 | IP Logged Quote Longey_Nowze

ok i just re-downloaded SLD_mixer from your site again, and I ran the game again and this is the log

Mac OS X Version 10.2.8 (Build 6R73)
Initializing SDL video subsystem.
SDL driver used: Quartz
SDL video subsystem initialized.
Initializing SDL audio subsystem.
SDL audio subsystem initialized.
Initializing SDL_mixer.
    opened sndmgr at 44100 Hz 16 bit stereo, 4096 bytes audio buffer
    compiled with SDL_mixer version: 1.2.4
    running with SDL_mixer version: 1.2.5
Set the video resolution to: 640x400x8
dyld: /Users/mat/Desktop/MoG/MoG.app/Contents/MacOS/MoG Undefined symbols:
/Users/mat/Desktop/MoG/MoG.app/Contents/MacOS/MoG undefined reference to _ov_open_callbacks expected to be defined in SDL_mixer
Oct 7 16:50:09 brushed crashdump: Crash report written to: /Users/mat/Library/Logs/CrashReporter/MoG.crash.log

2003-10-07 16:50:29.086 loginwindow[330] Could not find image named `bang'.


same thing?! I replaced the old files with the new ones and restarted just to make sure, where can I check the version?

Thank You
MaT
Back to Top View Longey_Nowze's Profile Search for other posts by Longey_Nowze Send Private Message Add to Buddy List
 
JEames
Admin Group
Admin Group
Avatar

Joined: 05 November 2002
Location: Catalonia
Posts: 498
Posted: 07 October 2003 at 16:25 | IP Logged Quote JEames

...may be the ogg file is corrupt or is not in the right place?



__________________
Jason Eames Lamarca
+34 639517737
Back to Top View JEames's Profile Search for other posts by JEames Visit JEames's Homepage Send Private Message Add to Buddy List
 
Popolon
Admin Group
Admin Group
Avatar

Joined: 05 November 2002
Location: Spain
Posts: 3135
Posted: 07 October 2003 at 17:12 | IP Logged Quote Popolon

Solved!!!!

It's been my fault! When I put the pre-compiled frameworks in the main page, I used newer versions that I downloaded to compile the MoG2-engine in Mac. However, the OSX bineary file available on the web was compiled with earlier versions... I'm sorry. I've already updated the Mac binary file. I hope you can ru nthe game now!!
Back to Top View Popolon's Profile Search for other posts by Popolon Visit Popolon's Homepage Send Private Message Add to Buddy List
 
Longey_Nowze
Newbie
Newbie
Avatar

Joined: 30 September 2003
Location: United Kingdom
Posts: 15
Posted: 07 October 2003 at 18:28 | IP Logged Quote Longey_Nowze

THANK YOU! IT WORKS NOW!!!

THANK YOU SO MUCH! IF YOU NEED ANY HELP IN THE FUTURE TESTING ANYTHING OR ANYTHING JUST TELL ME!

THANK YOU
MaT
Back to Top View Longey_Nowze's Profile Search for other posts by Longey_Nowze Send Private Message Add to Buddy List
 
Popolon
Admin Group
Admin Group
Avatar

Joined: 05 November 2002
Location: Spain
Posts: 3135
Posted: 08 October 2003 at 10:59 | IP Logged Quote Popolon

Great!
Back to Top View Popolon's Profile Search for other posts by Popolon Visit Popolon's Homepage Send Private Message Add to Buddy List
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

Page of 2
  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Powered by Web Wiz Forums version 7.01
Copyright ©2001-2003 Web Wiz Guide

This page was generated in 0,1719 seconds.